Author Topic: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready  (Read 18072 times)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« on: April 11, 2014, 10:16:04 am »
Hi all,

To upgrade your Zentyal 3.3 Community Edition to 3.4 you only need to update your 3.3 first to get the new zentyal-core 3.3.8. After that, an upgrade button will appear on the dashboard.

Please take into account that this upgrade involves also a distribution upgrade (from Ubuntu 12.04 to 13.10), so it make take a bit longer depending on the packages you have installed and your internet connection.

Remember also that only one community edition is maintained at the same time, so the end of life of Zentyal 3.3 has been reached already.
Zentyal Server Lead Developer

illunis

  • Guest
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #1 on: April 11, 2014, 01:31:39 pm »
Upgrade went very smooth indeed.

thnx guys  :D

Gopher

  • Zen Apprentice
  • *
  • Posts: 45
  • Karma: +7/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #2 on: April 11, 2014, 01:45:04 pm »
No upgrade button appears for me after core update

roswitina

  • Zen Apprentice
  • *
  • Posts: 48
  • Karma: +1/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #3 on: April 11, 2014, 03:37:40 pm »
Quote
No upgrade button appears for me after core update

as well ...

Rosi
« Last Edit: April 11, 2014, 03:39:12 pm by roswitina »

logdog

  • Zen Hero
  • *****
  • Posts: 623
  • Karma: +29/-2
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #4 on: April 12, 2014, 01:32:01 am »
No upgrade button appears for me after core update
+1

lapzenz

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #5 on: April 12, 2014, 01:44:02 am »
No upgrade button appears for me after core update
+1

gadgetusaf

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #6 on: April 12, 2014, 01:44:57 am »
My upgrade failed and i cannot continue the packages installs it failed with zentyal-ips
error
Reading database ... 312401 files and directories currently installed.)
Preparing to replace suricata 1.1.1-1 (using .../suricata_1.4.3-1_i386.deb) ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/suricata_1.4.3-1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 5
No apport report written because MaxReports is reached already
                                                               * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 5
Preparing to replace grep 2.10-1 (using .../archives/grep_2.14-3_i386.deb) ...
Unpacking replacement grep ...
Processing triggers for man-db ...
Processing triggers for install-info ...
Errors were encountered while processing:
 /var/cache/apt/archives/suricata_1.4.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
« Last Edit: April 12, 2014, 01:48:00 am by gadgetusaf »

pstrebel

  • Zen Apprentice
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #7 on: April 12, 2014, 09:54:33 am »
No upgrade button appears for me after core update

+1

Gopher

  • Zen Apprentice
  • *
  • Posts: 45
  • Karma: +7/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #8 on: April 14, 2014, 11:36:50 am »
Will this end up like my other box, stuck running 2.3 with no nice integrated complete or documented way to upgrade, forgotten and ignored in favour of the latest bleeding edge,buzzword filled and dubiously tested release....

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #9 on: April 14, 2014, 04:20:34 pm »
To the ones that are not seeing the button: can you confirm if your server is subscribed to Zentyal Remote or you have a commercial trial? If that's the case we will provide a new package soon.
Zentyal Server Lead Developer

chappy

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #10 on: April 14, 2014, 04:41:53 pm »
I also have no update button. My server is registered as community edition.

leojrfs

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #11 on: April 14, 2014, 04:50:04 pm »
Upgrade button doesnt appear, my server is registered on zentyal remote as a community edition


Thanks

Gopher

  • Zen Apprentice
  • *
  • Posts: 45
  • Karma: +7/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #12 on: April 14, 2014, 04:52:58 pm »
Yes community and registered for zentyal remote.
A recent (~1 month) install that has a developeda few quirky issues after some of the recent updates, fingers crossed a full upgrade will make them go away.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1985
  • Karma: +66/-2
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #13 on: April 14, 2014, 08:34:12 pm »
Ok, now if you upgrade to zentyal-core 3.3.9 the button should appear no matter the subscription. Thanks for the feedback!
Zentyal Server Lead Developer

gadgetusaf

  • Zen Apprentice
  • *
  • Posts: 4
  • Karma: +1/-0
    • View Profile
Re: Upgrade from Zentyal 3.3 to Zentyal 3.4 is ready
« Reply #14 on: April 15, 2014, 01:37:31 am »
My upgrade failed and i cannot continue the packages installs it failed with zentyal-ips
error
Reading database ... 312401 files and directories currently installed.)
Preparing to replace suricata 1.1.1-1 (using .../suricata_1.4.3-1_i386.deb) ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: warning: subprocess old pre-removal script returned error exit status 5
dpkg: trying script from the new package instead ...
 * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "stop" failed.
dpkg: error processing /var/cache/apt/archives/suricata_1.4.3-1_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 5
No apport report written because MaxReports is reached already
                                                               * NFQUEUE support not found !
 * Please ensure the nfnetlink_queue module is loaded or built in kernel
invoke-rc.d: initscript suricata, action "start" failed.
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 5
Preparing to replace grep 2.10-1 (using .../archives/grep_2.14-3_i386.deb) ...
Unpacking replacement grep ...
Processing triggers for man-db ...
Processing triggers for install-info ...
Errors were encountered while processing:
 /var/cache/apt/archives/suricata_1.4.3-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I had the same error, I reverted back to 3.3 reloaded a back up config, Hoping to see if there is an answer as to what caused this issue.

 

mailcat