Author Topic: Включаю модуль VPN - отрубает доступ с внутренней сетевухи.  (Read 1414 times)

Sand_man

  • Zen Samurai
  • ****
  • Posts: 280
  • Karma: +24/-0
    • View Profile
На работе настроил VPN сервер на zentyal. На втором сервере также на zentyal настроил VPN клиента. (Второй сервер унёс домой, чтоб проверить связь по VPN, надо между подразделениями сделать будет, поэтому схема пока такая - ADSL<->Zentyal<->Компьютер). Вот как только дома на сервере включаю модуль VPN - с компьютера пропадает соединение с Zentyal. Ни вебморда, ни ssh - нифига не работает. Пинг в вырубоне. Подключаю монитор к серверу - он живой. Причём VPN соединение поднято. Делаю sudo /usr/share/zentyal/unconfigure-module dns - перезагружаюсь, доступ опять есть. Делал уже поздно вечером, так что не сильно где смотрел, что стало. На работе сейчас смотрю - VPN соединение точно было, нормально. Никто не сталкивался с вырубоном таким? Может мелочь какая.

bubnov-pi

  • Zen Samurai
  • ****
  • Posts: 425
  • Karma: +27/-0
    • View Profile
Может быть банальность спрошу, но как клиент, удалённый сервер (дома) настройки IP не пересекающиеся ли с "локальным" интерфейсом получил?

Sand_man

  • Zen Samurai
  • ****
  • Posts: 280
  • Karma: +24/-0
    • View Profile
На VPNсервере по умолчанию настройка впн-адресов - 192.168.160.0, локальная сеть 10..., так что не должен бы. Но что то похожее, интерфейс недоступен становится. Буду на выходных смотреть. ifconfig надо глянуть, вчера уже ум за разум зашёл )))

logdog

  • Zen Hero
  • *****
  • Posts: 623
  • Karma: +29/-2
    • View Profile

Sand_man

  • Zen Samurai
  • ****
  • Posts: 280
  • Karma: +24/-0
    • View Profile
Короче, тормоз я. Слишком "много почитал" )) и с дури добавил в Advertised Networks и на клиенте и на сервере подсети друг друга. Ну и заворачивало трафик хрен знает куда. Оставил у клиента подсеть клиента, у сервера - сервера. Всё, пинги пошли от клиента в подсеть сервера, интернет работает, брат вебморда жива.