Author Topic: [solved] synchronization not working  (Read 815 times)

zippydan

  • Zen Monk
  • **
  • Posts: 80
  • Karma: +1/-0
    • View Profile
[solved] synchronization not working
« on: September 14, 2013, 02:10:22 am »
Running two 3.02 64 bit servers.

I can get the second server to connect as slave.  Master server sees the slave.  But no users or groups appear on the slave side.

I found this thread which seemed to solve the problem with certificates (or lack of) http://forum.zentyal.org/index.php/topic,14755.0.html

I did set up the CA on the master server, but never set up one for the webadmin.  Users and groups still wouldn't sync.  I set up the CA on the slave, still no users or groups.  After misreading the thread, I did setup a certificate on the webadmin, still no users or groups.  I revoked the wedadmin certificate and disabled that service in the CA.  Still no users or groups.

Where should I be looking for help?  Are there some logs that will tell me what is the problem and if the problem is certificates?

Also, from that same thread I read this link http://trac.zentyal.org/wiki/Documentation/Community/Document/SambaAndMasterSlave

Am I then to understand I need to remove the File Sharing module from the Master server?  What qualifies as a Domain Service?  What do I need to remove?

I reeeeeaaally need to get this working ASAP.

EDIT: Possibly, the CA Certificate bug is no longer an issue.  After looking at /var/log/zentyal/zentyal.log, the problem was with my slave's firewall and the gateway on the slave's side.  I needed to open the slave's firewall on port 443 for external connections, and the public IP of the Zentyal box was not correctly being forward to the internal IP.  So: all my fault haha
« Last Edit: September 14, 2013, 04:33:58 pm by zippydan »