Author Topic: Ошибки при обновлении  (Read 6925 times)

BrAWo

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Ошибки при обновлении
« on: July 16, 2013, 05:30:16 am »
Помогите люди добрые...

после попытки обновления компонентов zentyal говорит:

Данные модули установились не правильно. Вам необходимо исправить это перед их использованием или установкой новых модулей.
Для исправления ситуации, попробуйте выполнить эту команду в консоле:
sudo dpkg --configure -a

собственно результат:

Code: [Select]
Настраивается пакет zentyal-firewall (3.0.5) ...
DBD driver has not implemented the AutoCommit attribute at /usr/lib/perl5/DBI.pm line 717.
dpkg: не удалось обработать параметр zentyal-firewall (--configure):
 подпроцесс установлен сценарий post-installation возвратил код ошибки 255
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-openvpn:
 zentyal-openvpn зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-openvpn (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-squid:
 zentyal-squid зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-squid (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-antivirus:
 zentyal-antivirus зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-antivirus (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-samba:
 zentyal-samba зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-samba (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-trafficshaping:
 zentyal-trafficshaping зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-trafficshaping (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-dns:
 zentyal-dns зависит от zentyal-firewall, однако:
  Пакет zentyal-firewall пока не настроен.
dpkg: не удалось обработать параметр zentyal-dns (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-remoteservices:
 zentyal-remoteservices зависит от zentyal-openvpn, однако:
  Пакет zentyal-openvpn пока не настроен.
dpkg: не удалось обработать параметр zentyal-remoteservices (--configure):
 проблемы зависимостей -- оставляем не настроенным
dpkg: зависимости пакетов не позволяют настроить пакет zentyal-printers:
 zentyal-printers зависит от zentyal-samba (>= 3.0.13), однако:
  Пакет zentyal-samba пока не настроен.
dpkg: не удалось обработать параметр zentyal-printers (--configure):
 проблемы зависимостей -- оставляем не настроенным
При обработке следующих пакетов произошли ошибки:
 zentyal-firewall
 zentyal-openvpn
 zentyal-squid
 zentyal-antivirus
 zentyal-samba
 zentyal-trafficshaping
 zentyal-dns
 zentyal-remoteservices
 zentyal-printers

до этих радостных событий ещё зачет то обновил mysql до 5.5.31
как я понял проблема в этом
что теперь делать ? как исправить? спасите помогите

BrAWo

  • Zen Apprentice
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #1 on: July 17, 2013, 03:52:50 am »
Так и не осилил как исправить
просто переустановил.

hardcoreuk

  • Zen Warrior
  • ***
  • Posts: 112
  • Karma: +2/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #2 on: July 19, 2013, 02:44:11 pm »
http://trac.zentyal.org/ticket/6110 тут ответ!!!
Замените содержимое файла /etc/zentyal/logs.conf этим
https://raw.github.com/Zentyal/zentyal/master/main/core/conf/logs.conf

sarus

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #3 on: August 20, 2013, 05:11:23 pm »
Приветствую.
Не хочет обновляться 1 пакет из-за зависимости.
При выполнении  sudo apt-get upgrade
Code: [Select]
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Возможно, для исправления этих ошибок вы захотите воспользоваться «apt-get -f install».
Пакеты, имеющие неудовлетворённые зависимости:
 linux-generic-pae : Зависит: linux-headers-generic-pae (= 3.2.0.51.61) но 3.2.0.52.62 уже установлен
 linux-image-generic-pae : Зависит: linux-image-3.2.0-51-generic-pae но он не установлен
E: Неудовлетворённые зависимости. Попытайтесь использовать -f.
Выполняю sudo apt-get -f install
Code: [Select]
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Исправление зависимостей… Готово
Следующие пакеты устанавливались автоматически и больше не требуются:
  python-crypto vsftpd libnet-cups-perl libjs-jquery-ui linux-headers-3.2.0-43-generic-pae linux-headers-3.2.0-38-generic-pae linux-headers-3.2.0-41-generic-pae libtext-dhcpleases-perl php-mail-mime roundcube-core adzapper
  intltool-debian libicu48 python-paramiko roundcube-plugins libexporter-cluster-perl php-net-socket php5 squid3-common tftpd-hpa linux-headers-3.2.0-40 linux-headers-3.2.0-35 linux-headers-3.2.0-41 linux-headers-3.2.0-43
  linux-headers-3.2.0-38 linux-headers-3.2.0-44 linux-headers-3.2.0-39 linux-headers-3.2.0-45 linux-headers-3.2.0-48 php-mdb2-driver-mysql ncftp php-mdb2 screen libjs-jquery at po-debconf archivemail fetchmail
  linux-headers-3.2.0-44-generic-pae linux-headers-3.2.0-39-generic-pae php5-gd john-data duplicity libmcrypt4 php-pear roundcube-mysql php-net-smtp php5-pspell linux-headers-3.2.0-48-generic-pae python-gnupginterface
  ocsinventory-agent squid3 dansguardian linux-headers-3.2.0-45-generic-pae zentyal-ebackup libnet-server-perl php5-mcrypt bcrelay linux-headers-3.2.0-40-generic-pae linux-headers-3.2.0-35-generic-pae roundcube pptpd php5-intl
  libio-multiplex-perl libnet-cidr-perl libberkeleydb-perl php-auth libproc-daemon-perl php5-mysql dbconfig-common php5-cli msktutil tinymce isc-dhcp-server libapache2-mod-php5 libtext-csv-perl sshpass php5-common librsync1
  squid-langpack postgrey john libapache2-mod-ldap-userdir libaspell15 dmidecode libfile-readbackwards-perl php-mail-mimedecode
Для их удаления используйте «apt-get autoremove».
Будут установлены следующие дополнительные пакеты:
  linux-generic-pae linux-image-generic-pae
Пакеты, которые будут обновлены:
  linux-generic-pae linux-image-generic-pae
обновлено 2, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
не установлено до конца или удалено 2 пакетов.
Необходимо скачать 0 B/4 074 B архивов.
После данной операции, объём занятого дискового пространства возрастёт на 0 B.
Хотите продолжить [Д/н]? y
dpkg: зависимости пакетов не позволяют настроить пакет linux-image-generic-pae:
 linux-image-generic-pae зависит от linux-image-3.2.0-51-generic-pae, однако:
  Пакет linux-image-3.2.0-51-generic-pae не установлен.
dpkg: не удалось обработать параметр linux-image-generic-pae (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                                                                           dpkg: зависимости пакетов не позволяют настроить пакет linux-generic-pae:
 linux-generic-pae зависит от linux-image-generic-pae (= 3.2.0.51.61), однако:
  Пакет linux-image-generic-pae пока не настроен.
 linux-generic-pae зависит от linux-headers-generic-pae (= 3.2.0.51.61), однако:
  Версия linux-headers-generic-pae в системе 3.2.0.52.62.
dpkg: не удалось обработать параметр linux-generic-pae (--configure):
 проблемы зависимостей -- оставляем не настроенным
Отчёты apport не записаны, так как сообщение об ошибке указывает на повторную ошибку от предыдущего отказа.
                                                                                                           При обработке следующих пакетов произошли ошибки:
 linux-image-generic-pae
 linux-generic-pae
E: Sub-process /usr/bin/dpkg returned an error code (1)
Выдает такое. Не могу понять как исправить?

 

logdog

  • Zen Hero
  • *****
  • Posts: 623
  • Karma: +29/-2
    • View Profile
Re: Ошибки при обновлении
« Reply #4 on: August 20, 2013, 05:53:33 pm »
Зависит: linux-image-3.2.0-51-generic-pae но он не установлен

sarus

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #5 on: August 20, 2013, 06:45:07 pm »
И как быть если версия linux-headers-generic-pae в системе 3.2.0.52.62?

logdog

  • Zen Hero
  • *****
  • Posts: 623
  • Karma: +29/-2
    • View Profile
Re: Ошибки при обновлении
« Reply #6 on: August 20, 2013, 10:17:52 pm »
Установить 3.2.0-51, если он есть в репозитории.

SmertNik

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #7 on: October 10, 2013, 01:36:21 pm »
Установить 3.2.0-51, если он есть в репозитории.

у меня такая же ошибка.
 не могу установить данный пакет
Code: [Select]
sudo apt-get -f install linux-image-3.2.0-51-generic-pae
Reading package lists... Done
Building dependency tree
Reading state information... Done
linux-image-3.2.0-51-generic-pae is already the newest version.
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 linux-generic-pae : Depends: linux-image-generic-pae (= 3.2.0.51.61) but 3.2.0.54.64 is to be installed
                     Depends: linux-headers-generic-pae (= 3.2.0.51.61) but 3.2.0.54.64 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
также смотрел в /boot  там пишет что такое ядро есть...

Sand_man

  • Zen Samurai
  • ****
  • Posts: 270
  • Karma: +16/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #8 on: October 10, 2013, 02:06:48 pm »
Попробуй поставить не image, а просто linux-generic-pae

Sand_man

  • Zen Samurai
  • ****
  • Posts: 270
  • Karma: +16/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #9 on: October 10, 2013, 02:07:39 pm »
причём версии 3.2.0.54.64

SmertNik

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #10 on: October 10, 2013, 02:23:12 pm »
причём версии 3.2.0.54.64
не могу понять как это сделать,  можешь точную команду дать?

Sand_man

  • Zen Samurai
  • ****
  • Posts: 270
  • Karma: +16/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #11 on: October 10, 2013, 02:57:27 pm »
Извиняюсь, это я с версией ступил, конечно. Во все стороны сегодня дёргают. Если никто не отпишется - попозже что-нибудь отвечу. Завал на работе

Sand_man

  • Zen Samurai
  • ****
  • Posts: 270
  • Karma: +16/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #12 on: October 10, 2013, 07:08:26 pm »
На просторах предлагают просто:
sudo dpkg --remove linux-generic-pae
sudo apt-get install linux-generic-pae

Старые то ядра удалялись? Может со старого ядра загрузиться, новое недоустановленное удалить да по новому обновиться?

sarus

  • Zen Apprentice
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #13 on: October 14, 2013, 10:50:24 am »
Решение простое:
Code: [Select]
wget http://launchpadlibrarian.net/145792672/linux-image-3.2.0-51-generic-pae_3.2.0-51.77_i386.deb
sudo dpkg -i ~/linux-image-3.2.0-51-generic-pae_3.2.0-51.77_i386.deb

ps спс за подсказку logdog

926

  • Zen Monk
  • **
  • Posts: 50
  • Karma: +0/-0
    • View Profile
Re: Ошибки при обновлении
« Reply #14 on: October 16, 2013, 11:20:51 am »
Подскажите как побороть, не могу обновиться:

Code: [Select]
Do you want to continue [Y/n]? y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 134955 files and directories currently installed.)
Preparing to replace python-minimal 2.7.3-0ubuntu2 (using .../python-minimal_2.7.3-0ubuntu2.2_i386.deb) ...
find: invalid predicate `-delete'
dpkg: warning: subprocess old pre-removal script returned error exit status 1
dpkg - trying script from the new package instead ...
find: invalid predicate `-delete'
dpkg: error processing /var/cache/apt/archives/python-minimal_2.7.3-0ubuntu2.2_i386.deb (--unpack):
 subprocess new pre-removal script returned error exit status 1
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 /var/cache/apt/archives/python-minimal_2.7.3-0ubuntu2.2_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)