Author Topic: DHCP nao inicia [RESOLVIDO]  (Read 2572 times)

vinicius181

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
DHCP nao inicia [RESOLVIDO]
« on: June 12, 2013, 04:54:30 pm »
Tenho zentyal 2.2.9 em 3 empresas instalado. E nas 3 empresas deu problema com DHCP.
O DHCP nao inicia. Creio que seja algum problema com atualização automatica do zentyal.

segue abaixo log erro, zentyal.log. Se alguem puder me ajudar. to quebrando cabeça aqui ??

2013/06/11 13:41:34 INFO> Log.pm:118 EBox::Event::Dispatcher::Log::send - $VAR1 = bless( {
                 'source' => 'service',
                 'compMessage' => 'DHCP',
                 'level' => 'error',
                 'dispatchers' => [
                                    'any'
                                  ],
                 'timestamp' => 1370968893,
                 'duration' => 0,
                 'message' => 'Os seguintes módulos não estão em execução mas estão habilitados: DHCP
'
               }, 'EBox::Event' );
« Last Edit: June 13, 2013, 10:57:39 pm by vinicius181 »

Anderson Felipe

  • Zen Warrior
  • ***
  • Posts: 168
  • Karma: +7/-1
    • View Profile
Re: DHCP nao inicia
« Reply #1 on: June 12, 2013, 06:00:45 pm »
Pelo visto e o mesmo problema do nosso outro amigo do tópico http://forum.zentyal.org/index.php/topic,15554.0.html

No caso de vcs eu anotaria as configurações do dhcp e reinstalaria.

apt-get remove zentyal-dhcp

apt-get update
apt-get upgrade

apt-get install zentyal-dhcp

entre na interface e ative o módulo dhcp.

Experimente isso caso tenha possibilidade de executar.


Sds,

Anderson Felipe
Sds,

Anderson Felipe
(Estou de volta turminha do compartilhamento de informações 8)!!!)

marceloeng

  • Zen Warrior
  • ***
  • Posts: 135
  • Karma: +1/-0
    • View Profile
Re: DHCP nao inicia
« Reply #2 on: June 13, 2013, 05:30:20 pm »
Olá,

Tive o mesmo problema e foi resolvido fazendo o seguinte:

Editar o arquivo "/usr/share/zentyal/stubs/dhcp/apparmor-dhcp.profiles.mas"  e adicionar a linha "network packet raw," abaixo de "network packet packet,".

Busquei essa alternativa no fórum em inglês. http://forum.zentyal.org/index.php/topic,15477.msg63738.html#msg63738

Segundo eles é uma solução temporária.

Meu ambiente: Zentyal 2.2.9/Ubuntu 10.04


Abraço,
Marcelo

vinicius181

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: DHCP nao inicia
« Reply #3 on: June 13, 2013, 10:57:14 pm »
Ola Marceloeng!

Resolvido!
Adicionei a linha "network packet raw," e deu certo. DHCP iniciado.
Só lembrando para galera que tem que logar com usuário "root" para ter permissão de alterar.

obrigado

naner690

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: DHCP nao inicia
« Reply #4 on: August 15, 2013, 09:40:58 pm »
Ola Marceloeng!

Resolvido!
Adicionei a linha "network packet raw," e deu certo. DHCP iniciado.
Só lembrando para galera que tem que logar com usuário "root" para ter permissão de alterar.

obrigado

e facil resolver e so add um nova faixa de dchp para a rede.

entra em dchp.
nova faixa. e add um nova. e ja eras.

jgggr

  • Zen Apprentice
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: DHCP nao inicia [RESOLVIDO]
« Reply #5 on: October 27, 2013, 02:42:09 pm »
Obrigado pela resposta!

Após uma reinicialização do servidor me deparei também com o problema de dhcp não rodando. Realizei o procedimento como descrito por  marceloeng e deu certo, obrigado!

No meu caso, no entanto, como uso zentyal 2.0.23 o arquivo se encontra no seguinte caminho:

" /usr/share/ebox/stubs/dhcp/apparmor-dhcpd.profile.mas "

Adicionado a linha:

"network packet raw,"  (não esquecer da virgula no fim).

E funcionando!