Author Topic: Webapp Chat addon  (Read 2977 times)

mfett

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Webapp Chat addon
« on: May 13, 2013, 12:44:31 am »
Hi,
I have a some strange problems with Webapp addon for chat.
Well sometimes it get connected status sometimes not.
Also when you try to connect as other user it get connected.
Also I don't see all members of groups created on domain i webapp chat client. Some members are missing.
Also some user don't see all domain groups in webapp chat.
Generally it's not 100% functional all the time and it's not working same for all users.

I am using latest Firefox browser on Windows 8 or 7 when accessing Webapp.
Server is installed on Hyper-V virtualization.
Also it is behind NAT (IP Cop).
Same behavior from internal network or domain joined PC (no NAT) or from internet (NAT).

Core version    3.0.20
Software    No updates
System load    1.38, 1.31, 1.11
WebApp 1.3.1-41348 - ZCP 7.1.4-41394
« Last Edit: May 13, 2013, 11:49:56 am by mfett »

mfett

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Webapp Chat addon
« Reply #1 on: May 13, 2013, 02:34:19 pm »
I think that I have found what causes chat addon connection problem.
Well, another user was using chrome for testing webapp.
Also I have discovered that restarting zentyal jabber service restores chat addon connection on Firefox browser.
But when particular user open webapp with chrome chat connection is broken and I have to restart jabber service.

I know that Chrome is not officially supported but it seems that also in some way causes this problem.
Please note that Fat client (Miranda) has no problem connecting to jabber service even webapp has.

I hope all of this info would help resolving this problem in future.
« Last Edit: May 13, 2013, 02:37:03 pm by mfett »

vitaebela

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: Webapp Chat addon
« Reply #2 on: May 14, 2013, 07:59:21 pm »
No one from zentyal has comment?  :-\

Maybe to write same topic on Zarafa forums?

mfett

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Webapp Chat addon
« Reply #3 on: May 23, 2013, 01:10:04 pm »
Anyone, anything ? Does anybody else has this problem.

ichat

  • Zen Hero
  • *****
  • Posts: 795
  • Karma: +28/-16
  • RTFM!
    • View Profile
Re: Webapp Chat addon
« Reply #4 on: May 23, 2013, 03:25:45 pm »
you where right first time, you should post this on zarafa forum as zentyal is using thair stock version without modifications, 
All tips hints and advices are based on my personal experience.
As I try my best to be as accurate as possible, following my advice is always at your own risk,
I claim absolutely NO responsibility in any way!

mfett

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Webapp Chat addon
« Reply #5 on: May 23, 2013, 04:21:46 pm »
Unfortunately I have placed same post on Zarafa forum.
No reply for now.

https://forums.zarafa.com/showthread.php?9263-Webapp-chat-chrome-kill-jabber-connection