Author Topic: FTP configuration  (Read 1355 times)

0oOo0

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
FTP configuration
« on: May 03, 2013, 12:00:48 pm »
Hi

Are there any guides available that outline the steps to setting up FTP on Zentyal linux?  I have enabled the module, yet /srv/ftp doesn't even appear to exist.  I've tried googling for 'configure FTP zentyal' and I've done similar searches in the forums here, but I don't see any guide. 

Could it be that I'm just so new to all of this that I'm missing something that it totally obvious to everyone else?

j

Marcus

  • Forum Moderator
  • Zen Samurai
  • *****
  • Posts: 395
  • Karma: +12/-0
    • View Profile
    • Professional IT Service
Re: FTP configuration
« Reply #1 on: May 03, 2013, 08:32:14 pm »
Hello 0oOo0,

Zentyal FTP doc:
http://doc.zentyal.org/en/ftp.html

Best,

Marcus

0oOo0

  • Zen Apprentice
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: FTP configuration
« Reply #2 on: May 04, 2013, 12:07:07 am »
Hi Marcus

I should have said that I did previously try that page you linked to.  FTP has started working for anon access over a WAN and I've .  My connection is being throtteled at the moment by my ISP, perhaps that is why I could not connect before. 

I've enabled PAM but I can't seem to get into my user directories.  The client I am using to do so is using SFTP and access to personal directories is checked in on the server side.

Thanks

christian

  • Guest
Re: FTP configuration
« Reply #3 on: May 04, 2013, 06:31:55 am »
Could you please refine what your problem is?
At the very beginning, you said "I can't see /srv/ftp/" but now it looks like FTP works in anonymous mode but fails when using SFTP to access personal directory. Very confusing isn't it?

Did you try to investigate:
- disabling SSL (BTW if you search this forum, you will find multiple posts related to issues FTP + SSL)
- disabling "personal directory" and "restrict to personal directory"