Author Topic: Radius - Wifi AP  (Read 2046 times)

Mono

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +0/-0
    • View Profile
Radius - Wifi AP
« on: November 26, 2012, 03:32:54 pm »
Sziasztok!

Van egy TP-Link Access Pointom (TL-WA801ND típus), gondoltam beállítom úgy, hogy a Zentyal Radius szervere végezze az autentikációt. Jegyzem meg itt egyből az elején: soha semmi közöm nem volt még a Radiushoz, így lehet, hogy alapvető hibákat követek el.
Jelen pillanatban nem működik a dolog, ezért is hoztam létre ezt a topikot.

Lépésről lépésre a következőket csináltam:
Az AP-ban ez lett beállítva:


Zentyalban pedig így néz ki a történet:




Szóval adott egy közös jelszó, minkét oldalon ugyanazt állítottam be természetesen.
Mint látszik, az AP IP címe: 192.168.26.253, a Zentyal szerveré pedig a 30-as végződésű.

Hoztam létre egy felhasznalok nevű csoportot, majd tagjaként beállítva egy "peti" nevű usert.
A beállítások alapján - a fent említett gyakorlati tapasztalatommal a hátam mögött - azt gondolnám, ez esetben a felhasznalok csoport tagjai számára a Radius autentikáció engedélyezett.

Fogtam egy Windows 7-es laptopot, próbáltam csatlakozni az AP-ben kiajánlott hálózathoz, kért is szépen felhasználói nevet, jelszót. Beírtam a peti-t, illetve a peti jelszavát, a csatlakozás sikertelen volt. Néztem a /var/log/freeradius/radius.log-ot, ezek vannak benne:
Code: [Select]
Mon Nov 26 14:44:28 2012 : Info: Exiting normally.
Mon Nov 26 14:44:28 2012 : Info: Loaded virtual server inner-tunnel
Mon Nov 26 14:44:28 2012 : Info: Loaded virtual server <default>
Mon Nov 26 14:44:28 2012 : Info: Ready to process requests.
Mon Nov 26 14:45:03 2012 : Error: TLS Alert read:fatal:unknown CA
Mon Nov 26 14:45:03 2012 : Error:     TLS_accept: failed in SSLv3 read client certificate A
Mon Nov 26 14:45:03 2012 : Error: rlm_eap: SSL error error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca
Mon Nov 26 14:45:03 2012 : Error: SSL: SSL_read failed inside of TLS (-1), TLS session fails.
Mon Nov 26 14:45:03 2012 : Auth: Login incorrect (TLS Alert read:fatal:unknown CA): [peti] (from client 192.168.26.253/32 port 0 cli 00-18-DE-77-13-28)

Direkt hagytam benne az elejét is, az exiting és a loaded akkor volt, amikor valamit állítgattam a Radius-ban, majd jobb felül a "Beállítások mentése" gombra kattintottam.
De ha újra próbálok csatlakozni, akkor az "erroros" és az "authos" sorok által képezett versszak ismétlődik újra.

Tehát van valami próbálkozás, eljön a Radiusig az AP-ból a kérés, látszik a felhasználói név is, de valami tanúsítvány baja lehet.
Ezen még felbuzdulva gyorsan be is mentem a "Hitelesítésszolgáltató (CA)" menüpont alá, hamar létre is hoztam 10 évre egy új tanúsítványszolgáltatót, majd alatta a "Szolgáltatások tanúsítványa" almenüpontban engedélyeztem a Radius számára a dolgot.
Ez után újra próbáltam, de semmi változás nem volt.

Mit nézzek meg? Mit csinálok rosszul? Mit ajánlotok?


Szemy

  • Zen Apprentice
  • *
  • Posts: 44
  • Karma: +0/-1
    • View Profile
Re: Radius - Wifi AP
« Reply #1 on: November 26, 2012, 09:57:58 pm »
Szia,

Ő... bátortalanul szólok hozzá ...
nekem sem volt tapasztalatom Radius-al de a SSL ből kiindulva a [common name (CN)] a CA  és a kiállított tanúsítványnál helyesen van megadva? DNS be van állítva?

találtam egy hasonló problémát is itt a fórumon .. LINK

EAP-MSCHAP v2 Használsz csatlakozásnál ??
 
Segítség EAP-MSCHAP v2 | képekkel !PDF!

vagy

EAP-TTLS EAP-TTLS
EAP-TTLS - 2
« Last Edit: November 26, 2012, 10:57:41 pm by Juhász Gergely »

Szemy

  • Zen Apprentice
  • *
  • Posts: 44
  • Karma: +0/-1
    • View Profile
Re: Radius - Wifi AP
« Reply #2 on: November 29, 2012, 02:16:01 am »
Siker?

Mono

  • Zen Monk
  • **
  • Posts: 63
  • Karma: +0/-0
    • View Profile
Re: Radius - Wifi AP
« Reply #3 on: December 07, 2012, 07:07:45 pm »
Nem, még nem volt időm ezzel mélyebben foglalkozni, a Zentyal többi része van most előtérben. De amint fejlemény van, jelzem!