Author Topic: Zentyal 3: Como usar o usuário logado automaticamente na autenticação do proxy?  (Read 7564 times)

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Salve galera...

Estou com um servidor Zentyal 3 em testes, com AD e proxy autenticado e está funcionando belezinha... porém nos clientes, após os usuários se logarem no domínio toda vez que abre o navegador tem que autenticar de novo...

Existe uma forma de forçar o browser a usar o usuário logado pra autenticar no proxy?

Gilberto Ferreira

  • Zen Hero
  • *****
  • Posts: 509
  • Karma: +12/-1
    • View Profile
Sim

Embora eu ainda não tenha testado isso, você pode ativar a autenticação via Kerberos.
Outra opção é ativar o NTLM...
Dá uma pesquisada no google sobre o assunto...

Att

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Realmente.. .jogo a toalha...

A opção do kerberos deve estar lá de decoração mesmo... não surte efeito nenhum... marcando ou desmarcando é a mesma coisa!

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Olá Wemerson,

Você integrou com um AD Microsoft ou construiu o AD no próprio Zentyal? Fiz o teste usando a integração com o Windows 2008 e funcionou!

Abraços,
Jorge Quintão

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Somente com Zentyal como AD master... sem integrar cou outro AD.

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Olá Wemerson,

Ok! Este teste ainda não fiz, mas creio que irá funcionar também... Descobrimos alguns bugs no módulo de proxy, acabo de conversar com o pessoal da Zentyal e um novo módulo com os bugs corrigidos deve ser lançado amanhã...

Abraços,
Jorge Quintão

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Olá Wemerson,

Ok! Este teste ainda não fiz, mas creio que irá funcionar também... Descobrimos alguns bugs no módulo de proxy, acabo de conversar com o pessoal da Zentyal e um novo módulo com os bugs corrigidos deve ser lançado amanhã...

Abraços,
Jorge Quintão

Tem alguma relação com o kerberos ou era outra coisa?!

Vai ver é isso que tava impedindo de rodar!

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Olá Wemerson,

Tinha um problema relacionado a geração de linhas muito longas no squid.conf... Estão trabalhando nesta correção...

Abraços,
Jorge Quintão

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Olá Wemerson,

Tinha um problema relacionado a geração de linhas muito longas no squid.conf... Estão trabalhando nesta correção...

Abraços,
Jorge Quintão

Ah ok... então não tem relação com o problema de autenticação... o jeito é esperar que no novo release após essas correções essa parte funcione!

igor.matos

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Opa.... alguém sabe como anda essa atualização?

Gostei muito do Zentyal, mas o firewall ficou intermitente e agora a interface do Squid não obedece o que eu quero. :(

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Olá Igor,

Parece que a equipe de desenvolvedores está trabalhando em algumas correções do módulo samba e squid... Talvez seja necessário gerar uma versão do módulo samba com alguns patches da Zentyal... Logo que tiver saído a versão nova, informamos por aqui...

Abraços,
Jorge Quintão

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Nossa, parece ter sido um problema mais sério hein?

Até hoje não sairam as correções!

jquintao

  • Moderator
  • Zen Hero
  • *****
  • Posts: 648
  • Karma: +14/-0
  • jquintao
    • View Profile
    • NetSol
Olá Wemerson,

Existe um detalhe interessante para o funcionamento do SSO que muitos não prestam atenção (após ler a documentação). Na hora de configurar o proxy, vc não pode informar o IP do mesmo. É necessário usar o nome da forma:

host.dominio.local

No meu caso:

netsolfw.netsol.local

E ao pingar este hostname na estação, é necessário que aponte para o IP do Zentyal...

Abraços,
Jorge Quintão

wemersonrv

  • Zen Samurai
  • ****
  • Posts: 331
  • Karma: +4/-0
    • View Profile
Ah legal... entendi!

antonelly

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +1/-0
    • View Profile
wemersonrv, tudo bom?
Gostaria de saber se você conseguiu resolver esse problema. Também não consigo fazer com que as máquinas (Win XP) utilizem no proxy a autenticação feita quando logaram no domínio.