Author Topic: No me puedo conectar ni por HTTP ni por HTTPS  (Read 12614 times)

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #15 on: August 24, 2012, 09:09:19 pm »
Entra al servidor por SSH con putty desde otro equipo pues  :-\

y tendras 3 consolas, una vez hecho eso podras realizar el procedimiento.

Si no tienes instalado SSH instalalo, asi:

Code: [Select]
sudo apt-get update
Code: [Select]
sudo apt-get upgrade
Code: [Select]
sudo apt-get install ssh
Verificas que este corriendo el servicio con

Code: [Select]
sudo service ssh start
Deberia responderte asi

Code: [Select]
start: Job is already running: ssh
Si hasta alli estamos bien, con putty desde otro equipo entras a la IP del servidor Zentyal por el puerto 22

el usuario y la password tu las sabes..

Suerte!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #16 on: August 24, 2012, 09:32:13 pm »
OK mira estos son los resultados

Code: [Select]
Comando1

usuario@ubuntudicon:~$ tail -f /var/log/zentyal/zentyal.log
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 13:56:37 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:17:02 INFO> Service.pm:716 EBox::Module::Service::restartService - Restarting service for module: events
2012/08/24 14:26:40 INFO> Service.pm:716 EBox::Module::Service::restartService - Restarting service for module: audit
2012/08/24 14:26:41 INFO> Redis.pm:766 EBox::Config::Redis::_initRedis - Starting redis server
2012/08/24 14:26:42 INFO> Service.pm:716 EBox::Module::Service::restartService - Restarting service for module: events
2012/08/24 14:26:43 INFO> Service.pm:716 EBox::Module::Service::restartService - Restarting service for module: logs
2012/08/24 14:26:45 INFO> Service.pm:716 EBox::Module::Service::restartService - Restarting service for module: apache
2012/08/24 14:26:47 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:48 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:49 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:50 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:51 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:52 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:53 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:54 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:55 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:56 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:57 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:58 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:26:59 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:27:00 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:27:01 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132
2012/08/24 14:27:02 ERROR> Sudo.pm:213 EBox::Sudo::_rootError - root command /usr/share/zentyal/apache2ctl start failed.
Error output: Illegal instruction

Command output: .
Exit value: 132


Code: [Select]

Comando 2

usuario@ubuntudicon:~$ tail -f /var/log/zentyal/error.log


En el 2do comando no aparecio nada

Todos los servicios iniciaron OK al reiniciar Zentyal


Gracias por tu tiempo y ayuda!!!!  :D
Siempre con la mente clara!

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #17 on: August 24, 2012, 09:49:12 pm »
Hola

.Bueno creo q ese es el problema que apache no esta escuchando por el puerto 443, si he instalado zentyal unas 5 veces desde 0 es poquito y el mismo proceso lo estoy realizando en mi casa y funciona perfecto. No se que estara bloqueando el puerto

.Sobre los los logs zentyal.log y error.log, en el post anterior fueron los resultados que me arrojo

. El servicio ssh esta iniciado, ya me he conectado desde Putty y WinCSP

Puedo configurar otro puerto para conectarme a Zentyal?

Thanks!
« Last Edit: August 24, 2012, 09:53:15 pm by felipemb »
Siempre con la mente clara!

ronald

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #18 on: August 24, 2012, 09:56:37 pm »
felimp,

Probablemente la instalación no finalizó correctamente, sugiero que primero reinstales los paquetes zentyal-core, zentyal-common, zentyal-network y verifiques nuevamente con netstat si se levanta un servicio en el puerto 443

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #19 on: August 24, 2012, 09:59:21 pm »
Creo lo mismo, apache no esta ejecutando como corresponde.

Cuando instalaste el Ubuntu Server, si quierias instalar Apache o un Servidor WEB ¿?

Que seleccionaste, veo que esta instalado apache segun tu LISTEN pero al parecer es la instalacion por default de Ubuntu Server y no la de Zentyal.

Borra apache completamente

Code: [Select]
sudo apt-get purge apache2
Code: [Select]
sudo update-rc.d -f apache2 remove
Y ahora reinstala los modulos zentyal-core, zentyal-common, zentyal-network

Y nos comentas como te fue..

Suerte!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #20 on: August 24, 2012, 10:27:54 pm »
 :( :(

les comento paso a paso lo que realice

1. En la instalacion inicial de Ubuntu, cuando me pide que seleccione para que voy a usar el servidor y que paquetes quiero instalar yo simpletemente sigo derecho sin seleccionar ningun paquete, porque ninguno me interesa (asi le he hecho antes)

2. He desinstalado perfectamente apache, con los dos comandos que me has dado

3. Vuelvo a instalar zentyal-core (dejo el puerto 443 por defecto), instalo zentyal-common y zentyal-network

4. Ejecuto "netstat -tunap | grep -i listen"

--
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      714/redis-server
tcp        0      0 127.0.0.1:6380          0.0.0.0:*               LISTEN      6022/redis-server
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1639/apache2   
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      2482/sshd       
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      614/postgres   
tcp6       0      0 :::22                   :::*                    LISTEN      2482/sshd       
tcp6       0      0 ::1:5432                :::*                    LISTEN      614/postgres   
--

Sin exito aun  :( esto es muy frustrante y saber que lo tengo instalado igual en mi casa y el puerto 443 esta perfecto y escuchando

A Uds. les agradezco infinitamente sus aportes e ideas.  :D
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #21 on: August 24, 2012, 10:32:01 pm »
:( :(

les comento paso a paso lo que realice

1. En la instalacion inicial de Ubuntu, cuando me pide que seleccione para que voy a usar el servidor y que paquetes quiero instalar yo simpletemente sigo derecho sin seleccionar ningun paquete, porque ninguno me interesa (asi le he hecho antes)

2. He desinstalado perfectamente apache, con los dos comandos que me has dado

3. Vuelvo a instalar zentyal-core (dejo el puerto 443 por defecto), instalo zentyal-common y zentyal-network

4. Ejecuto "netstat -tunap | grep -i listen"

--
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      714/redis-server
tcp        0      0 127.0.0.1:6380          0.0.0.0:*               LISTEN      6022/redis-server
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      1639/apache2   
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      2482/sshd       
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      614/postgres   
tcp6       0      0 :::22                   :::*                    LISTEN      2482/sshd       
tcp6       0      0 ::1:5432                :::*                    LISTEN      614/postgres   
--

Sin exito aun  :( esto es muy frustrante y saber que lo tengo instalado igual en mi casa y el puerto 443 esta perfecto y escuchando

A Uds. les agradezco infinitamente sus aportes e ideas.  :D

ELIMINA todos los paquetes zentyal y los instalas desde 0, cuando usas "remove" solo te borra los paquetes, pero los conf siguen alli.

Con "purge" por lo general la desinstalacion es mas limpia.

Suerte!!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #22 on: August 25, 2012, 03:00:13 am »
No amigos nadaa...

Desinstale todo lo volvi a instalar con su puerto por defecto y nadaa

Desinstale todo y lo volvi a instalar con puerto diferente y nadaa

--
root@ubuntudicon:/home/usuario# netstat -tunap | grep -i listen
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      3700/redis-server
tcp        0      0 127.0.0.1:6380          0.0.0.0:*               LISTEN      3789/redis-server
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2769/apache2   
tcp        0      0 0.0.0.0:22              0.0.0.0:*               LISTEN      564/sshd       
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      3652/postgres   
tcp6       0      0 :::22                   :::*                    LISTEN      564/sshd       
tcp6       0      0 ::1:5432                :::*                    LISTEN      3652/postgres   
root@ubuntudicon:/home/usuario#
--

El problema es q no se deja configurar el puerto https, porq? nose la verdad es la 1era vez que me sucede

Les agradezco mucho su tiempo es muy valioso
Siempre con la mente clara!

Escorpiom

  • Zen Hero
  • *****
  • Posts: 897
  • Karma: +25/-1
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #23 on: August 25, 2012, 05:39:39 am »
Hola Felipe,

Primero que todo, cual version estas intentando de instalar? Pues en la pagina que mencionaste hay instrucciones tanto para 2.2 como para 3.0.
Zentyal 2.2.x va sobre Ubuntu 10.04 LTS.
Zentyal 3.0 beta va sobre Ubuntu 12.04 LTS.
El modulo "network" es primordial que lo instalas, no lo puedes saltar.
Y el Apache como servidor web es diferente al Apache de Zentyal.
Por HTTP si te conectas bien, pues aparece la pagina de Apache asi que esto esta funcionando.
Lo que no funciona es el Zentyal-apache, y eso lo vemos tambien en los registros. Ahora falta descubrir el porque.

Me avisa pues.
Marcus' Rule:
Blanks & capitals = avoid it and you'll avoid problems...

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #24 on: August 25, 2012, 06:34:25 pm »
Hola Escorpiom,

Estoy instalando la version 2.2.x que es la que esta hecha para Ubuntu 10.04.4 LTS.

Te cuento que ya he instalado los modulos zentyal-core zentyal-network zentyal-common, pero sin exito alguno

No tengo la mas minima idea de porque no se configura el puerto 443 para conectarme a Zentyal como lo hacia siempre!

Gracias por tu tiempo  ;D
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #25 on: August 25, 2012, 07:48:05 pm »
Hola Escorpiom,

Estoy instalando la version 2.2.x que es la que esta hecha para Ubuntu 10.04.4 LTS.

Te cuento que ya he instalado los modulos zentyal-core zentyal-network zentyal-common, pero sin exito alguno

No tengo la mas minima idea de porque no se configura el puerto 443 para conectarme a Zentyal como lo hacia siempre!

Gracias por tu tiempo  ;D

Estimado, lo que podemos hacer es que instales un nuevo servidor Ubuntu y me des acceso ssh, una vez hecho esto te instalo Zentyal por SSH.

Me avisas por privado, una vez que funcione todo ok, indicamos aca cual era el error que se cometia para que el resto no tenga problemas a futuro.

Suerte!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #26 on: August 25, 2012, 09:38:54 pm »
woww amigo en serio lo harias?? woww excelente

Mira ya tengo instalado el ubuntu 10.04.4 LTS sin ningun paquete instalado, solo openssh-server

Osea totalmente limpioo para empezar a instalar Zentyal

Gracias  :D

PD. Te envio los datos de acceso por inbox
Siempre con la mente clara!

Escorpiom

  • Zen Hero
  • *****
  • Posts: 897
  • Karma: +25/-1
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #27 on: August 26, 2012, 04:45:19 am »
Linda comunidad! Asi vamos bien, espero que todo sale bien, no olviden contar como les fue.

Saludos.
Marcus' Rule:
Blanks & capitals = avoid it and you'll avoid problems...

nicoace

  • Zen Apprentice
  • *
  • Posts: 17
  • Karma: +0/-0
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #28 on: August 30, 2012, 02:29:02 pm »
Pues como instale Ubuntu server 10.04.4 LTS por seguridad se instala sin interfaz grafica, entonces no sabria si por localhost me responde, hay alguna manera de comprobar la conexion a Zentyal sin interfaz grafica y sin ningun navegador?.

Mira realmente ya habia hecho esta instalacion pero algo me debe estar bloqueando la conexion a Zentyal o algo configure mal pero por mas que pienso no se que sera...

Un pequeño aporte, para probar si podes ingresar sin interfaz gráfica, podes probar con un "telnet" al puerto 443, o bien con "lynx" que es un navegador sin interfaz gráfica.

¡Suerte!

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #29 on: August 30, 2012, 11:30:32 pm »
Gracias amigo por tu aporte, pero no responde el puerto 443, es decir no se configura para Zentyal ya comprobamos los puertos que estan en funcionamiento. Ese es el problema que tengo sin solucion alguna por el momento

Thanks  :D
Siempre con la mente clara!