Author Topic: No me puedo conectar ni por HTTP ni por HTTPS  (Read 12601 times)

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
No me puedo conectar ni por HTTP ni por HTTPS
« on: August 13, 2012, 05:52:37 pm »
Hola foreros,

Sinceramente para que yo postee un problema es porque ya he intentado 1001 cosas para solucionar mi problema sin exito. Intentare describir mi problema lo mas breve y claro posible.

Tengo instalado Ubuntu 10.04 LTS e instale el repositorio de Zentyal segun las instrucciones dadas en esta pagina:
http://trac.zentyal.org/wiki/Documentation/Community/Installation/InstallationGuide?redirectedfrom=Document/Documentation/InstallationGuide

Instalo perfectamente Zentyal, tengo configuradas dos tarjetas de red

1 interna IP = 10.0.0.1
2 externa IP = 190.85.**.***

Al intentar conectarme como siempre le he hecho es abrir Firefox y digitar https://10.0.0.1 o https://190.85.**.*** como no tengo ningun modulo de Zentyal instalado entonces por las dos IPs me podria conectar, pero lo unico que obtengo es un error de no se puede conectar como si la pagina no existiera o no la encontrara, cuando intento conectarme por http://10.0.0.1 o http://190.85.**.*** me aparece un mensaje "IT'S WORKS! .........." pero no carga la consola de Zentyal ya que solo reconoce por HTTPS (443)

Realmente no entiendo el error y no se porque no me conecta, esta instalacion la he realizado muchas veces y esta ha sido la unica que no he podido, la interfaz externa (190.85.**.***) responde perfectamente a las instalaciones los comandos apt-get update y upgrade funcionan perfectamente y la interfaz interna (10.0.0.1) responde desde otro equipo al dar ping, es decir no es un problema de configuracion de las tarjetas de red (o al menos eso creo)

Alguien puede darme un luz para saber que estoy haciendo mal.

Quedo pendiente de alguien que pueda darme una ayuda.


Gracias  :D
Siempre con la mente clara!

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #1 on: August 15, 2012, 01:46:28 am »
In English....

Translate By Bing!

---
Hi friends,

Sincerely I postee a problem is because I already tried to 1001 things to solve my problem without success. I will try to describe my problem the more brief and clear as possible.

I have installed Ubuntu 10.04 LTS and install the Zentyal repository according to the instructions on this page:
http://trac.zentyal.org/wiki/documentation/community/installation/InstallationGuide?redirectedfrom=document/documentation/InstallationGuide

Zentyal install perfectly, I have two network cards configured

1 LAN IP = 10.0.0.1
2 WAN IP = 190.85. **. **

When you try to connect me as I have always made open Firefox and enter https://10.0.0.1 or https://190.85.**.*** as I have not module Zentyal then installed by the two IPs I could connect, but the only thing I get is an error of cannot connect as if this page does not exist or not found it, when I try to connect by http://10.0.0.1 or http://190.85.**.*** I get a message "IT's WORKS!..." but does not load the Zentyal console since only recognized by HTTPS (443)

I really do not understand the error and not because I did not connect, this installation it've been many times and this has been the only one that I could not, the external interface (190.85. **. **) responds perfectly to facilities the command apt-get update / upgrade work perfectly and the internal interface (10.0.0.1) response from another computer to ping, it is not a problem of configuration of network cards (or at least I think)

Someone can give me a light to know what I'm doing wrong.

I am awaiting someone who can give me a help.


Thank you
--

Somebody help me?  ;D ;D ;D ;D ;D
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #2 on: August 15, 2012, 04:49:58 am »
Instalaste ya los modulos de "Network Configuration" y "Firewall" ¿?
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #3 on: August 15, 2012, 06:58:25 am »
1ero gracias por contestar  :D

Respondiendo tu pregunta no, no he instalado nada, es decir instale el Zentyal desde el repositorio y de hay me conecto via Web desde otro pc con la IP que le he dejado y ya puedo conectarme a Zentyal para configurarlo por 1era vez e instalar los modulos que necesito

Me gusta instalar 1ero Ubuntu y despues desde el repositorio instalar Zentyal asi instala de una manera mas limpia para mi parecer.

Como comentaba antes este proceso ya lo habia realizado antes, pero esta vez me ha sido imposible conectarme a la consola de Zentyal

Gracias por tu tiempo!
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #4 on: August 15, 2012, 07:00:25 am »
1ero gracias por contestar  :D

Respondiendo tu pregunta no, no he instalado nada, es decir instale el Zentyal desde el repositorio y de hay me conecto via Web desde otro pc con la IP que le he dejado y ya puedo conectarme a Zentyal para configurarlo por 1era vez e instalar los modulos que necesito

Me gusta instalar 1ero Ubuntu y despues desde el repositorio instalar Zentyal asi instala de una manera mas limpia para mi parecer.

Como comentaba antes este proceso ya lo habia realizado antes, pero esta vez me ha sido imposible conectarme a la consola de Zentyal

Gracias por tu tiempo!

Pero no entiendo, instalado los repo, y te pudiste conectar ya por https? o aun no puedes.. ¿?
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #5 on: August 15, 2012, 09:36:52 pm »
No amigo ese es mi problema que no me puedo conectar por la IP que es https://10.0.0.1 se queda pensando y dice pagina no disponible, desde ningun navegador me responde

Es como si esa IP no estuviera enrutada a la consola de Zentyal, pero la IP responde ping desde cualquier otro PC, algo tendre mal pero no he sabido que es

Gracias por tu tiempo  :D
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #6 on: August 15, 2012, 09:43:16 pm »
y puedes entrar por localhost directo en la maquina que tienes instalado zentyal ?
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #7 on: August 15, 2012, 09:51:27 pm »
Pues como instale Ubuntu server 10.04.4 LTS por seguridad se instala sin interfaz grafica, entonces no sabria si por localhost me responde, hay alguna manera de comprobar la conexion a Zentyal sin interfaz grafica y sin ningun navegador?.

Mira realmente ya habia hecho esta instalacion pero algo me debe estar bloqueando la conexion a Zentyal o algo configure mal pero por mas que pienso no se que sera...
Siempre con la mente clara!

acon

  • Moderator
  • Zen Samurai
  • *****
  • Posts: 454
  • Karma: +18/-0
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #8 on: August 23, 2012, 07:59:15 pm »
Te recomiendo que instales del ISO de zentyal. de esta forma instala el escritorio ligero lxde que te facilita la depuración desde consola.
Por otra parte, desde el iso seguro que se te instala todo correctamente.

ronald

  • Zen Apprentice
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #9 on: August 24, 2012, 12:16:35 am »
felipemb,

Ejecuta el siguiente comando y publicalo para observar los puertos de los servicios

$ netstat -tunap | grep -i listen

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #10 on: August 24, 2012, 07:30:35 pm »
Te recomiendo que instales del ISO de zentyal. de esta forma instala el escritorio ligero lxde que te facilita la depuración desde consola.
Por otra parte, desde el iso seguro que se te instala todo correctamente.

Amigo gracias por tu tiempo!

De la manera que me dices si me sirve, es decir si instalo Zentyal desde la ISO todo funciona ok! pero debo mencionar que estoy instalando zentyal sobre un S.O que se llama Citrix XenServer y para optimizar el rendimiento de la maquina virtual es necesario instalar "XenTools" que lamentablemente no es compatible con Zentyal, por eso debo instalar 1ero Ubuntu 10.04.4 LTS en modo PV para asi poder optimizar el rendimiento de mi maquina virtual.

Y te cuento que esta instalacion la he realizado masomenos unas 7 veces en diferentes servidores y me ha funcionado todo normalmente, pero esta vez la verdad estoy completamente confundido

Gracias por tu tiempo y espero me explique porque quiero hacerlo de esta manera

felipemb,

Ejecuta el siguiente comando y publicalo para observar los puertos de los servicios

$ netstat -tunap | grep -i listen

Gracias igualmente por tu tiempo!

Este es el resultado del comando:

--
root@ubuntudicon:/home/usuario# netstat -tunap | grep -i listen
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      727/redis-server
tcp        0      0 127.0.0.1:6380          0.0.0.0:*               LISTEN      742/redis-server
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      844/apache2     
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      706/postgres   
tcp6       0      0 ::1:5432                :::*                    LISTEN      706/postgres   
root@ubuntudicon:/home/usuario#
--

Espero pueda resultar de ayuda


GRACIAS  :D
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #11 on: August 24, 2012, 07:43:57 pm »
Te recomiendo que instales del ISO de zentyal. de esta forma instala el escritorio ligero lxde que te facilita la depuración desde consola.
Por otra parte, desde el iso seguro que se te instala todo correctamente.

Amigo gracias por tu tiempo!

De la manera que me dices si me sirve, es decir si instalo Zentyal desde la ISO todo funciona ok! pero debo mencionar que estoy instalando zentyal sobre un S.O que se llama Citrix XenServer y para optimizar el rendimiento de la maquina virtual es necesario instalar "XenTools" que lamentablemente no es compatible con Zentyal, por eso debo instalar 1ero Ubuntu 10.04.4 LTS en modo PV para asi poder optimizar el rendimiento de mi maquina virtual.

Y te cuento que esta instalacion la he realizado masomenos unas 7 veces en diferentes servidores y me ha funcionado todo normalmente, pero esta vez la verdad estoy completamente confundido

Gracias por tu tiempo y espero me explique porque quiero hacerlo de esta manera

felipemb,

Ejecuta el siguiente comando y publicalo para observar los puertos de los servicios

$ netstat -tunap | grep -i listen

Gracias igualmente por tu tiempo!

Este es el resultado del comando:

--
root@ubuntudicon:/home/usuario# netstat -tunap | grep -i listen
tcp        0      0 127.0.0.1:6379          0.0.0.0:*               LISTEN      727/redis-server
tcp        0      0 127.0.0.1:6380          0.0.0.0:*               LISTEN      742/redis-server
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      844/apache2     
tcp        0      0 127.0.0.1:5432          0.0.0.0:*               LISTEN      706/postgres   
tcp6       0      0 ::1:5432                :::*                    LISTEN      706/postgres   
root@ubuntudicon:/home/usuario#
--

Espero pueda resultar de ayuda


GRACIAS  :D

Por que dices que no es compatible con Zentyal XEN-Tools ¿?

En ese resultado no estan en modo LISTEN los puertos 80 o 443, por lo que no se esta ejecutando tu consola web, tienes el apache2 instalado pero bajo el puerto 844, prueba poniendo http://IP:844 y ve si es un servicio que usas o si tiene interfaz web.

Si no te muestra nada ejecuta el siguiente comando.

Code: [Select]
sudo service zentyal restart
y me comentas si te carga todos los modulos ok.

Saludos!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #12 on: August 24, 2012, 07:57:52 pm »
1. Zentyal si se deja instalar sobre XenServer sin problemas, pero no se deja optimizar con XenTools ya que Ubuntu 10.04.4 no es compatible (o no tiene PV), para que sea compatible toca hacer una instalacion especial, segun este link (http://community.citrix.com/display/xs/Installing+Ubuntu+Server+10.04+(32bit+and+64bit)+LTS)

2. Tambien se me hace raro que no este el puerto 443, que es el que yo dejo por defecto en la instalacion

3. Con el puerto IP:844 tampoco carga

4. Reinicio el servicio y todo OK

--
root@ubuntudicon:/home/usuario# sudo service zentyal restart
 * Stopping Zentyal module: logs       [ OK ]
 * Stopping Zentyal module: events       [ OK ]
 * Stopping Zentyal module: audit       [ OK ]
 * Stopping Zentyal module: apache       [ OK ]
 * Starting Zentyal module: audit       [ OK ]
 * Starting Zentyal module: events       [ OK ]
 * Starting Zentyal module: logs       [ OK ]
 * Starting Zentyal module: apache       [ OK ]
root@ubuntudicon:/home/usuario#
--

Agradezco todas las ayudas e ideas, yo seguire intentando hasta dar con la solucion
Siempre con la mente clara!

pcready.cl

  • Zen Samurai
  • ****
  • Posts: 290
  • Karma: +13/-1
  • Zentyal Installer in Chile
    • View Profile
    • PC Ready Chile SpA
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #13 on: August 24, 2012, 08:05:53 pm »
1. Zentyal si se deja instalar sobre XenServer sin problemas, pero no se deja optimizar con XenTools ya que Ubuntu 10.04.4 no es compatible (o no tiene PV), para que sea compatible toca hacer una instalacion especial, segun este link (http://community.citrix.com/display/xs/Installing+Ubuntu+Server+10.04+(32bit+and+64bit)+LTS)

2. Tambien se me hace raro que no este el puerto 443, que es el que yo dejo por defecto en la instalacion

3. Con el puerto IP:844 tampoco carga

4. Reinicio el servicio y todo OK

--
root@ubuntudicon:/home/usuario# sudo service zentyal restart
 * Stopping Zentyal module: logs       [ OK ]
 * Stopping Zentyal module: events       [ OK ]
 * Stopping Zentyal module: audit       [ OK ]
 * Stopping Zentyal module: apache       [ OK ]
 * Starting Zentyal module: audit       [ OK ]
 * Starting Zentyal module: events       [ OK ]
 * Starting Zentyal module: logs       [ OK ]
 * Starting Zentyal module: apache       [ OK ]
root@ubuntudicon:/home/usuario#
--

Agradezco todas las ayudas e ideas, yo seguire intentando hasta dar con la solucion

Ok, entonces vuelve abre 3 panel SSH

En el primero ejecuta
Code: [Select]
tail -f /var/log/zentyal/zentyal.log
En el segundo
Code: [Select]
tail -f /var/log/zentyal/error.log
Y en el tercero
Code: [Select]
sudo service zentyal restart
Copiame ambos logs de manera separada con bajo [ code ] [ /code ]

Para ver cual es el error..

Suerte!
Email: contacto@pcready.cl
Teléfono: (+56 32) 314 0883
Skype: pcready.cl
Web: https://www.pcready.cl

felipemb

  • Zen Monk
  • **
  • Posts: 62
  • Karma: +1/-0
  • La base del conocimiento + experiencia = TODOO!
    • View Profile
Re: No me puedo conectar ni por HTTP ni por HTTPS
« Reply #14 on: August 24, 2012, 09:00:58 pm »
Tengo un problema y es que no puedo abrir mas consolas como es normal con Ctrl  + Alt + F1,F2,F3,.....

Como te dije antes me toco cambiar algunas cosas para poder instalar XenTools y asi queda mi consola SSH ahora es hvc0

--
Ubuntu 10.04.4 LTS ubuntudicon hvc0 (hvc0 en vez de tty0)

ubuntudicon login:
--

Si sabes alguna manera de abrir otra consola SSH con hvc te lo agradezco

Hay alguna manera de reconfigurar el puerto 443 al servicio apache2?
Siempre con la mente clara!