Author Topic: ebox-egroupware ready for testing  (Read 13763 times)

javi

  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
ebox-egroupware ready for testing
« on: February 25, 2009, 06:32:45 pm »
We  are pleased to announce the release of a new eBox module that integrates eGroupware into the eBox universe. We are certain that this new module will help many users who are in the need of having a complete groupware  solution plus the bunch of the amazing services already provided by eBox.

Having eGroupware in eBox means that you will take full advantage of all its modules out of the box, bringing to eBox new features such as: calendar sharing, address book, webmail and much more.

We have worked to provide you with a seamless integration of eGroupware and eBox. Thanks to our LDAP backend,  users and groups created in eBox will show up in your eGroupware installation. And of course, the necessary mail infrastructure is also provided by eBox.

We have just uploaded the first beta version to our unstable repository and it's ready to be tested by the community. Give it a shot and let us know what you think about it. A ready-to-go groupware solution is just one "apt-get install"  away on eBox now :)

JAK

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #1 on: February 26, 2009, 03:55:23 pm »
Hello

There where two things that I noticed after installing egroupware with "apt-get update && install ebox-egroupware":
1.) when running the egroupware installation test an error is found:

This might take a while, please wait ...
ErrorChecking file-permissions of .././sitemgr/doc for not world writable:
.././sitemgr/doc does not exist !!!


2.) eBox Software Management module has no knowledge that egroupware is installed:
Component     Installed version 
eBox - eGroupware     none

With regards
Jüri Kirch

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: ebox-egroupware ready for testing
« Reply #2 on: February 26, 2009, 08:31:35 pm »
Quote
1.) when running the egroupware installation test an error is found:

This might take a while, please wait ...
ErrorChecking file-permissions of .././sitemgr/doc for not world writable:
.././sitemgr/doc does not exist !!!

I can't reproduce this. But is eGroupware working? Have you enabled the module?

Quote
2.) eBox Software Management module has no knowledge that egroupware is installed:
Component     Installed version
eBox - eGroupware     none

ebox-software refreshes its cache every night, you can force a refresh executing sudo ebox-software

Regards,

J. A. Calvo
Zentyal Server Lead Developer

jbenicky

  • Zen Apprentice
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #3 on: March 04, 2009, 07:45:30 pm »
What software is used for groupware? I'm mainly interested in webmail.

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: ebox-egroupware ready for testing
« Reply #4 on: March 04, 2009, 08:06:21 pm »
The software used is eGroupware 1.4. eGroupware 1.4 comes with a webmail called Felamimail.
Zentyal Server Lead Developer

shortbus

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Help with ebox-egroupware
« Reply #5 on: March 08, 2009, 11:21:45 pm »
I installed ebox-egroupware from the unstable repository. The install went fine and I configured egroupware as I normally would from the /setup/index.php.

egroupware appears to work fine after I set it up but the egroupware add-in in ebox gives an error. "An internal error has ocurred. This is most probably a bug, relevant information can be found in the logs."

Can someone tell me the proper way to install egroupware with ebox-egroupware or direct me to the documentation?

Thanks

Shortbus

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: ebox-egroupware ready for testing
« Reply #6 on: March 09, 2009, 08:58:35 am »
Hi!

You don't have to configure egroupware as normally, eBox does it for you.

In fact, if you configure it with the traditional method you can create some conflict, specially if you create the users from inside egroupware instead of from the eBox interface.

The only you need to do to have eGroupware working is enabling the module on the "Module status" section. Later you may configure the mail domain from the "eGroupware" menu of eBox or change user permissions.

If you do the things this way and still get the same error you can find the detailed error in /var/log/ebox/ebox.log, and it would be useful if you paste it here.

Hope this helps!

Regards,

J.A. Calvo
« Last Edit: March 09, 2009, 09:02:04 am by J. A. Calvo »
Zentyal Server Lead Developer

shortbus

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #7 on: March 09, 2009, 11:03:58 pm »
OK, I did it the proper way. I did a fresh install of ebox and enabled mail and webserver and then enabled egroupware. I still got:

"An internal error has ocurred. This is most probably a bug, relevant information can be found in the logs." when I clicked on eGroupware to configure it. What have I missed?

Here's the tail of the ebox.log it is what was genreated when I clicked the egroupware

# tail -f /var/log/ebox/ebox.log
2009/03/09 17:48:50 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName RetrievalServices does not exist.
2009/03/09 17:49:18 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName DomainTable does not exist.
2009/03/09 17:49:27 DEBUG> CompositeManager.pm:142 EBox::Model::CompositeManager::composite - composite General does not exist.
2009/03/09 17:49:27 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName BadHeadersPolicy does not exist.
2009/03/09 17:49:27 DEBUG> CompositeManager.pm:142 EBox::Model::CompositeManager::composite - composite VDomains does not exist.
2009/03/09 17:49:31 DEBUG> CompositeManager.pm:142 EBox::Model::CompositeManager::composite - composite ObjectPolicy does not exist.
2009/03/09 17:49:31 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName ExternalFilter does not exist.
2009/03/09 17:49:31 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName SMTPAuth does not exist.
2009/03/09 17:49:31 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName SMTPOptions does not exist.
2009/03/09 17:49:31 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName RetrievalServices does not exist.
2009/03/09 17:52:23 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName VMailDomain does not exist.
2009/03/09 17:52:23 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName DefaultApplications does not exist.
2009/03/09 17:52:23 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName PermissionTemplates does not exist.
2009/03/09 17:52:23 ERROR> ModelProvider.pm:243 EBox::Model::ModelProvider::AUTOLOAD - Undefined method isImapEnabled


Now, even though I gave a user name and and password for the egroupware header admin, I am still unable to log in.

(also please note the spelling of occurred)

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: ebox-egroupware ready for testing
« Reply #8 on: March 10, 2009, 11:51:42 am »
Hi again!

I can't reproduce this on a fresh install and I'm afraid that the information found in your ebox.log is not very useful.

Could you please enable the debug mode on /etc/ebox/99ebox.conf and repeat the same process to get more information about the error?

Thanks for your testing and for the spelling correction :)

Regards,

J.A. Calvo
Zentyal Server Lead Developer

JAK

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #9 on: March 10, 2009, 01:36:42 pm »
Hello

I enabled debug mode in "/etc/ebox/99ebox.conf".
When enabling egroupware and trying to open egroupware module in eBox I get the same error "An internal error has...".

Here is the output of /var/log/ebox/ebox.log:
Quote
Error output:
Command output: .
Exit value: 1
2009/03/10 14:20:41 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: egroupware
2009/03/10 14:21:42 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName VMailDomain does not exist.
2009/03/10 14:21:46 DEBUG> LogFiltering.pm:70 EBox::Events::Model::Watcher::LogFiltering::new - Missing argument: tableInfo
2009/03/10 14:21:46 WARN> Events.pm:623 EBox::Events::__ANON__ - model EBox::Events::Model::Watcher::LogFiltering cannot be instantiated
2009/03/10 14:21:47 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName DefaultApplications does not exis
2009/03/10 14:21:47 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName PermissionTemplates does not exis
2009/03/10 14:21:47 ERROR> ModelProvider.pm:243 EBox::Model::ModelProvider::AUTOLOAD - Undefined method isImapEnabled

With regards
Jüri Kirch

J. A. Calvo

  • Zentyal Staff
  • Zen Hero
  • *****
  • Posts: 1986
  • Karma: +67/-3
    • View Profile
    • http://blogs.zentyal.org/jacalvo
Re: ebox-egroupware ready for testing
« Reply #10 on: March 10, 2009, 01:50:58 pm »
Could you please paste also the previous lines above "Error output:" to see which command is failing?

Regards,

J.A. Calvo
Zentyal Server Lead Developer

shortbus

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #11 on: March 10, 2009, 02:13:17 pm »
I tried it once again, clean install from the ebox install Ubuntu 8.04 LTS iso.

Same error and unable to log into eGroupware header admin even though I gave a user name and password during the ebox-egroupware configuration.

Attached in my entire ebox.log with debugging turned on. I hope this helps.

One thought, what is the proper order to install and then configure ebox and egroupware? Before I tried ebox-egroupware, I tried ebox and installed RoundCube on my test machine, that worked great but I really want the egroupware features. Installing eGroupware normally worked but didn't integrate properly with ebox. ebox-egroupware does not work at all.

Shortbus

JAK

  • Zen Apprentice
  • *
  • Posts: 22
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #12 on: March 10, 2009, 02:38:07 pm »
Hello

Here is the output:

Code: [Select]
2009/03/10 14:20:29 INFO> Manager.pm:601 EBox::ServiceModule::Manager::__ANON__ - File /etc/amavis/conf.d/amavisd.conf does not exist. So we won't compute it
2009/03/10 14:20:35 INFO> Global.pm:360 EBox::Global::saveAllModules - Saving config and restarting services: firewall mailfilter egroupware
2009/03/10 14:20:35 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: firewall
2009/03/10 14:20:38 DEBUG> LogFiltering.pm:70 EBox::Events::Model::Watcher::LogFiltering::new - Missing argument: tableInfo
2009/03/10 14:20:38 WARN> Events.pm:623 EBox::Events::__ANON__ - model EBox::Events::Model::Watcher::LogFiltering cannot be instantiated
2009/03/10 14:20:40 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: mailfilter
2009/03/10 14:20:40 ERROR> Sudo.pm:185 EBox::Sudo::_rootError - root command /usr/bin/test -f /var/lib/ebox/tmp//trainSpam failed.
Error output:
Command output: .
Exit value: 1
2009/03/10 14:20:41 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: egroupware
2009/03/10 14:21:42 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName VMailDomain does not exist.
2009/03/10 14:21:46 DEBUG> LogFiltering.pm:70 EBox::Events::Model::Watcher::LogFiltering::new - Missing argument: tableInfo
2009/03/10 14:21:46 WARN> Events.pm:623 EBox::Events::__ANON__ - model EBox::Events::Model::Watcher::LogFiltering cannot be instantiated
2009/03/10 14:21:47 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName DefaultApplications does not exis
2009/03/10 14:21:47 DEBUG> CompositeManager.pm:393 EBox::Model::CompositeManager::_inferModuleFromComposite - compositeName PermissionTemplates does not exis
2009/03/10 14:21:47 ERROR> ModelProvider.pm:243 EBox::Model::ModelProvider::AUTOLOAD - Undefined method isImapEnabled
2009/03/10 14:37:38 DEBUG> LogFiltering.pm:70 EBox::Events::Model::Watcher::LogFiltering::new - Missing argument: tableInfo
2009/03/10 14:37:38 WARN> Events.pm:623 EBox::Events::__ANON__ - model EBox::Events::Model::Watcher::LogFiltering cannot be instantiated
2009/03/10 14:41:58 ERROR> Sudo.pm:185 EBox::Sudo::_rootError - root command test -e /etc/amavis/conf.d/amavisd.conf failed.
Error output:
Command output: .
Exit value: 1
2009/03/10 14:41:58 INFO> Manager.pm:601 EBox::ServiceModule::Manager::__ANON__ - File /etc/amavis/conf.d/amavisd.conf does not exist. So we won't compute it
2009/03/10 14:42:02 INFO> Global.pm:360 EBox::Global::saveAllModules - Saving config and restarting services: firewall mailfilter
2009/03/10 14:42:02 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: firewall
2009/03/10 14:42:05 DEBUG> LogFiltering.pm:70 EBox::Events::Model::Watcher::LogFiltering::new - Missing argument: tableInfo
2009/03/10 14:42:05 WARN> Events.pm:623 EBox::Events::__ANON__ - model EBox::Events::Model::Watcher::LogFiltering cannot be instantiated
2009/03/10 14:42:07 INFO> Module.pm:155 EBox::Module::save - Restarting service for module: mailfilter
2009/03/10 14:42:07 ERROR> Sudo.pm:185 EBox::Sudo::_rootError - root command /usr/bin/test -f /var/lib/ebox/tmp//trainSpam failed.

BR
Jüri Kirch

javi

  • Zen Hero
  • *****
  • Posts: 1042
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #13 on: March 10, 2009, 04:24:33 pm »
shortbus,

Would it be possible for you to join #ebox on irc.freenode.net to try track down your issue?

shortbus

  • Zen Apprentice
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: ebox-egroupware ready for testing
« Reply #14 on: March 10, 2009, 05:15:34 pm »
Javi,

I looked for you there. Let's make a time...

Shortbus